Error Running EOM for protein-DNA complex

Linear (OLIGOMER), and non-linear (MIXTURE) analysis, singular value decomposition (SVDPLOT), addition of missing fragments (BUNCH, CORAL), analysis of flexible systems (EOM/RANCH & GAJOE), flexible refinement of high-resolution models (SREFLEX)
Post Reply
Message
Author
arko
Member
Posts: 7
Joined: 2015.08.27 19:29

Error Running EOM for protein-DNA complex

#1 Post by arko » 2015.08.27 19:59

Hi,

I am trying to run eom for a protein dna complex. The protein has two domains and has two different DNA molecules linked to it. Specifying only the protein sequence in the fasta file and specifying the two dna molecules as separate pdbs related to the two domains of the protein gives the following error at the beginning of the run:
... starts making models ...
[ 1%] *** Error in `eom': malloc(): memory corruption: 0x0000000003220a70 ***

Program received signal SIGABRT: Process abort signal.

Backtrace for this error:

Could you please comment on what could be the source of error and how to circumvent it?...Another related question is if there is a limit to the size of the DNA/RNA that can be fed into eom?

Thanks a lot in advance,

Best regards,

Arko

User avatar
AL
Administrator
Posts: 632
Joined: 2007.08.03 18:55
Location: EMBL Hamburg, Germany
Contact:

version?

#2 Post by AL » 2015.08.28 11:31

Which ATSAS version do you have?
Please type 'eom --version' and post the output.

Alex
Active member
Posts: 692
Joined: 2007.08.09 21:10
Location: Planet Earth

Re: Error Running EOM for protein-DNA complex

#3 Post by Alex » 2015.08.28 12:45

just my 2 cents: when i ran EOM on protein-RNA complexes (it was perhaps 2 eom revisions ago:), i had problems with
modeled parts clashing the RNA.

arko
Member
Posts: 7
Joined: 2015.08.27 19:29

Re: Error Running EOM for protein-DNA complex

#4 Post by arko » 2015.08.28 13:16

Hi,
I am using eom 2.0...here is the output of version query:
eom 2.0 (r5575)
Copyright (c) ATSAS Team, EMBL, Hamburg Outstation, 2007 - 2014
As Alex pointed out, this is my question too... does eom take into account steric clashes for the DNA or RNA as well?

Thanks a lot,

Arko

Alex
Active member
Posts: 692
Joined: 2007.08.09 21:10
Location: Planet Earth

Re: Error Running EOM for protein-DNA complex

#5 Post by Alex » 2015.08.28 13:40

As Alex pointed out, this is my question too... does eom take into account steric clashes for the DNA or RNA as well?
My gut feeling is no, since it only does the C-alpha/C-alpha clash check. In other words, it only checks what it actually models, but
there is a chance that EOM became more advanced and I am wrong here.

arko
Member
Posts: 7
Joined: 2015.08.27 19:29

Re: Error Running EOM for protein-DNA complex

#6 Post by arko » 2015.08.28 15:55

Hi Alex,
I also think so..however this memory allocation corruption does not make sense to me...any clue?

Thanks,

Arko

arko
Member
Posts: 7
Joined: 2015.08.27 19:29

Re: Error Running EOM for protein-DNA complex

#7 Post by arko » 2015.08.28 15:55

sorry meant memory corruption! :)

Alex
Active member
Posts: 692
Joined: 2007.08.09 21:10
Location: Planet Earth

Re: Error Running EOM for protein-DNA complex

#8 Post by Alex » 2015.08.28 17:33

try running without dna. does it work? check your dna - is there anything exotic?
also try to ran ranch first? does it still cuz a problem? does it cuz a problem on other OS (in case you
run it on some not anymore supported ones)?

HTH, Alex

User avatar
AL
Administrator
Posts: 632
Joined: 2007.08.03 18:55
Location: EMBL Hamburg, Germany
Contact:

Re: Error Running EOM for protein-DNA complex

#9 Post by AL » 2015.08.31 11:14

Please send the input data, the input parameters and the possible output (.log files etc.) to atsas(at)embl-hamburg(.)de - we will investigate it. Thanks!

arko
Member
Posts: 7
Joined: 2015.08.27 19:29

Re: Error Running EOM for protein-DNA complex

#10 Post by arko » 2015.09.29 17:32

Hi Alex, Dear Administrator,
I apologize for this late reply. I have systematically investigated the problem and it turns out to be the 2nd DNA molecule that either ranch or eom (which uses ranch for the model generation part) cannot handle. Ranch works fine if only one of the DNA molecules is added. Any thoughts?. Unfortunately I cannot share the input files due to restrictions.
Another aspect which I think could be a great inclusion in future versions of eom would be a steric clash check between the protein and nucleic acids or other ligands added ( a general overall steric clash penalty maybe?).

Best regards,

Arko

arko
Member
Posts: 7
Joined: 2015.08.27 19:29

Re: Error Running EOM for protein-DNA complex

#11 Post by arko » 2015.09.29 17:34

Oh I forgot to mention that without the DNA it also runs fine and the DNA does not have any exotic things..I am using atsas on debian jessie..is it backdated yet? :lol:

ckerr
Active member
Posts: 86
Joined: 2015.03.25 09:03
Location: EMBL Hamburg

Re: Error Running EOM for protein-DNA complex

#12 Post by ckerr » 2015.10.01 09:32

If you cannot share your input data, could you try to reproduce the problem with some similar data which you are able to share? Otherwise we will almost certainly not be able to fix it.

arko
Member
Posts: 7
Joined: 2015.08.27 19:29

Re: Error Running EOM for protein-DNA complex

#13 Post by arko » 2015.10.01 10:30

Hi Ckerr,

I will try to reproduce the problem with some similar data and get back to you.

Thanks a lot,

Regards,

Arko

Alex
Active member
Posts: 692
Joined: 2007.08.09 21:10
Location: Planet Earth

Re: Error Running EOM for protein-DNA complex

#14 Post by Alex » 2016.12.02 20:39

hi Arko
just out of curiosity - did you manage to fix your problem?

Cheers, Alex

Post Reply