problem in CRYSON batch mode

Calculation of SAXS and SANS profiles (CRYSOL, CRYSON), superposition of models (SUPCOMB, DAMAVER, DAMCLUST), database DARA
Post Reply
Message
Author
mj
Guest
Posts: 2
Joined: 2013.01.24 03:55

problem in CRYSON batch mode

#1 Post by mj » 2013.03.22 09:53

I use CRYSON to simulate the SANS curve from PDB files. When I specify "-d2o 0 -dro -0.0562" as arguments (to simulate the SANS in H2O curve)
, there appears an error message saying

Error: Illegal keyword value:
Keyword # 2: [-DRO] = []

When I set positive values for "dro" or in the interacting mode, it works. But, I'd like to calculate the SANS in H2O curve in batch mode.
I use CRYSON ver 2.7 in Mac OSX 10.5.8.

Thank you very much in advance.

sachrysts
Active member
Posts: 70
Joined: 2011.09.07 15:53
Location: Stanford

Re: problem in CRYSON batch mode

#2 Post by sachrysts » 2013.03.25 13:22

Currently, it is not possible to set negative values via the command line options.

If you want to use cryson in batch mode, you could create an answer-file. This would be a text file with the answers to the questions of the interactive mode on each line, respectively. Then you can use input redirection on the command line, e.g.
cryson < myanswers.txt

mj
Guest
Posts: 2
Joined: 2013.01.24 03:55

Re: problem in CRYSON batch mode

#3 Post by mj » 2013.04.09 06:44

Thank you very much for your response. I was able to calculate that with an answer-file.

ckerr
Active member
Posts: 86
Joined: 2015.03.25 09:03
Location: EMBL Hamburg

Re: problem in CRYSON batch mode

#4 Post by ckerr » 2016.04.12 13:36

Since ATSAS 2.7.0 it is now possible to specify negative values on the command line

Post Reply