ATSAS installation guide for the Mac

ATSAS for Linux and Mac, general installation issues, ATSAS online etc.
Message
Author
Yann
Active member
Posts: 44
Joined: 2010.11.03 11:31
Location: Vrije Universiteit Brussel

#16 Post by Yann » 2012.02.10 16:07

Hi guys,

in the end I had to change usr/lib64 like this... post it in case anybody else has the same problem:

export DYLD_LIBRARY_PATH=${DYLD_LIBRARY_PATH}:/usr/lib64

Now it works!!!

Thanks a bunch guys!!! Now I can re-start using the power of SAXSMAN!!!

Yann

sachrysts
Active member
Posts: 70
Joined: 2011.09.07 15:53
Location: Stanford

#17 Post by sachrysts » 2012.02.10 16:14

Yann wrote:Hi guys,

in the end I had to change usr/lib64 like this... post it in case anybody else has the same problem:

export DYLD_LIBRARY_PATH=${DYLD_LIBRARY_PATH}:/usr/lib64

Now it works!!!

Thanks a bunch guys!!! Now I can re-start using the power of SAXSMAN!!!

Yann
This how you set it up if you are running the Bourne-Again Shell (BASH).

Yann
Active member
Posts: 44
Joined: 2010.11.03 11:31
Location: Vrije Universiteit Brussel

#18 Post by Yann » 2012.02.10 16:20

Okay, thanks for the info... I'm not a computer wizard so I'm very ignorant when it comes to all these 'technical details'...

Thanks again and cheers,

Yann

Yann
Active member
Posts: 44
Joined: 2010.11.03 11:31
Location: Vrije Universiteit Brussel

Re: ATSAS installation guide for the Mac

#19 Post by Yann » 2013.02.12 12:21

Hi guys,

I have three questions:

1) I installed the new ATSAS for Mac (I am running on Lion). I opened Primus but couldn't perform any action. For example, when I try to average, primus says the file avrg001.dat does not exist! Same for when I try to merge. Also Guinier and p(r) analysis did not work for some reason.

2) I tried removing the whole package and re-installing everything. When I try to open Primus now, I get the following error message:

objc[2487]: Class QCocoaWindowCustomThemeFrame is implemented in both /Library/Frameworks/QtGui.framework/Versions/4/QtGui and /Applications/ATSAS/lib/libQtGui.4.8.0.dylib. One of the two will be used. Which one is undefined.

3) When I try to open Sasdoc, this is what I get:

Qt internal error: qt_menu.nib could not be loaded. The .nib file should be placed in QtGui.framework/Versions/Current/Resources/ or in the resources directory of your application bundle.
Abort trap: 6

Any idea what could be going on?

Thanks for your help,

Yann

franke
Administrator
Posts: 408
Joined: 2007.08.10 11:09
Contact:

Re: ATSAS installation guide for the Mac

#20 Post by franke » 2013.02.12 18:14

Hi everyone. I double checked the install package for 10.7 and you are right, it was broken. Today I rebuilt and verified the package. Please download the updated 10.7 package, remove the /Applications/ATSAS folder of the previous installation and install again. You should now see /Applications/ATSAS/primus.app and primus should run from the command line as well.

Please let me know if any of the problems mentioned here persists.

A package for 10.8 should become available with the next release.

Thanks for the reports and apologies for the inconvenience.

Cheers

Daniel

Yann
Active member
Posts: 44
Joined: 2010.11.03 11:31
Location: Vrije Universiteit Brussel

Re: ATSAS installation guide for the Mac

#21 Post by Yann » 2013.02.12 18:31

Hi Daniel,

I downloaded the new package. I can open Primus now, but whatever I try to do, I get the following message (see picture).

Thanks for your help,

Yann
Attachments
atsas_problem.tif
atsas_problem.tif (5.23 KiB) Viewed 3462 times

franke
Administrator
Posts: 408
Joined: 2007.08.10 11:09
Contact:

Re: ATSAS installation guide for the Mac

#22 Post by franke » 2013.02.12 18:41

Ok, that's not helpful :(

Please check the path to the binaries in the settings: Settings -> Configure primus
If this is empty (it shouldn't be, but mine here is), then set it to /Applications/ATSAS/bin, or add the same directory to the global PATH. That should do it.

Yann
Active member
Posts: 44
Joined: 2010.11.03 11:31
Location: Vrije Universiteit Brussel

Re: ATSAS installation guide for the Mac

#23 Post by Yann » 2013.02.12 18:50

Hi Daniel,

now it works: the path was indeed empty!

Thanks for all your help ;),

Yann

Post Reply