atsas 2.5.2-1 bunch segmentation fault

ATSAS for Linux and Mac, general installation issues, ATSAS online etc.
Post Reply
Message
Author
rlc1
Guest
Posts: 2
Joined: 2014.04.23 19:34

atsas 2.5.2-1 bunch segmentation fault

#1 Post by rlc1 » 2014.04.23 19:55

I am trying to solve a problem for one of our users who has encountered a segmentation fault when running bunch.

I have tried installing both the Debian6 and Ubuntu12.04 versions (via the .tar files since I don't install in default locations, but on an NFS-mounted disk for all our computers to access). The actual computer in use has Debian testing installed, but there doesn't appear to be a problem of incompatible system libraries. A portion of the output where it fails looks like this:

Fitting range in fractions of Smax ..... < 1.000 >:
ESTRG -W- : Nrg = 0 estimated, 5 taken

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x480C9D in _gfortran_random_seed_i8
#1 0x46DE66 in __libc_csu_init
#2 0x2AF072C7041F
#3 0x42B19F in r2c_expres_
#4 0x42C8B4 in r02r2c1_
#5 0x450117 in i05wrc_
#6 0x439D49 in outdnum_
#7 0x40EA3D in probcadist1_
Segmentation fault

This was from the Debian6 version. The Ubuntu12.04 version did not provide a backtrace so has less information. The full terminal output is also attached. We get the same error when using the version in our SBGrid installation and using the atsas2.5.1-2 version.
Attachments
error_posted.log
(3.39 KiB) Downloaded 168 times

franke
Administrator
Posts: 408
Joined: 2007.08.10 11:09
Contact:

Re: atsas 2.5.2-1 bunch segmentation fault

#2 Post by franke » 2014.04.24 18:03

Thanks for the info and the log.

To be able to reproduce the issue we'd need all input files, i.e. the .pdb and .dat as well.
In case you do not want to post them here, you can also then them to my-forum-account-name@embl-hamburg.de

rlc1
Guest
Posts: 2
Joined: 2014.04.23 19:34

Re: atsas 2.5.2-1 bunch segmentation fault

#3 Post by rlc1 » 2014.04.24 19:08

Hello,

Thanks for your response here. I tried to send the files directly via e-mail, but I don't understand what e-mail address I should use (clearly not "my-forum-account-name@embl-hamburg.de" and "saxier@embl-hamburg.de" fails with a "no local mail delivery" error).

Cheers,
Robert

SaxsMax
Administrator
Posts: 349
Joined: 2007.08.03 19:16

Re: atsas 2.5.2-1 bunch segmentation fault

#4 Post by SaxsMax » 2014.04.25 11:07

Please try to open the data file in primus/qt,
determine the Rg and Guinier interval using
Tools->Radius of Gyration and save the data as a new file.
This will remove bad data points at the beginning
and should be usable in bunch.

Post Reply