MacOS install problems

ATSAS for Linux and Mac, general installation issues, ATSAS online etc.
Post Reply
Posts: 2
Joined: 2017.08.15 11:28

MacOS install problems

#1 Post by abeerasz » 2017.08.15 11:35

When i try to download the 2.8.2 version on macOS Sierra and download the .tar file and open it, it asks about the password but the problem is a lock appears just beside it and i cant enter anything. Is that normal or what?

Active member
Posts: 46
Joined: 2014.03.05 17:56

Re: MacOS install problems

#2 Post by sasha » 2017.08.30 17:13

Dear abeerasz,

I just tried the installation package on Mavericks. It asked me to enter the password in the Terminal, for executing as sudo.
Do you have permissions to run commands as sudo?

Try the following:
1. Open the terminal app.
2. Go to where you have the downloaded ATSAS (probably cd ~/Downloads)
3. Untar the downloaded file with: > tar -zxvf ATSAS-2.8.2-2_OSX.tar or double click on it.
4. There should be an "ATSASinstall.command" file in your downloads folder.
5. Try to execute it using sudo on the terminal: > sudo ATSASinstall.command
6. When prompted, type in your user password.
7. It should unpack and install ATSAS.

If you don't have sudo permissions this means that you are not the administrator of your computer, please check with your local IT.
Otherwise make sure your user can administer your machine.

BTW, I haven't seen this lock icon you mention, could you send us a screenshot?



Posts: 1
Joined: 2018.07.08 03:56

Re: MacOS install problems

#3 Post by mcbonaccorsi » 2018.07.08 04:03

Dear Sasha,
I'm trying to install ATSAS 2.8.3 on Mavericks and I followed your instructions but the terminal does not allow me to type the password, what should I do? I have also tried to double click it

Post Reply