Page 1 of 1

ALMERGE question

Posted: 2016.10.05 11:28
by Yann

I am trying to use ALMERGE for a zero concentration extrapolation. I fail to produce any output, because ALMERGE has trouble reading the concentration from my .dat files. Does the concentration have to be entered in the .dat file in a specific way or on a specific line for ALMERGE to find it? Also, it seems the -c option only works on one file (at least in my hands): is there a way to use the -c option on multiple files simultaneously?

I have tried using ALMERGE from PRIMUS using the 'extrapolate' button (all curves buffer-subtracted and normalised for concentration, and concentrations filled out in the right boxes in the gui) and have tried it from the command-line. Both giving me the same error 'invalid or missing value for concentration'.

Any help would be highly appreciated.



Re: ALMERGE question

Posted: 2016.10.05 15:53
by Yann
Found it for those interested. The concentration must be on line 25 of the dat file (before the data) and must be given in as 'Concentration: 0.1' if the sample has a concentration of 0.1 mg/ml.

ALMERGE will now find the concentration in the file header.




Posted: 2016.10.06 14:14
by AL
Wow, what's wrong with the -c option?

Code: Select all

-c	--concentration <VALUE> <DATAFILE>	Concentration of the following data set, overrides the concentration read from the file header.
ALMERGE will read the concentration value from the file if the format is compatible with the open source libsaxsdocument library. If you wish to add the concentration to the file header such that ALMERGE can read it - the second line should contain "c= <number>", e.g. "c= 0.1 mg/ml".