Primus - graphics issues [Ubuntu]

Small angle scattering software (except ATSAS)
Post Reply
Message
Author
ttubiana
Member
Posts: 3
Joined: 2015.04.15 16:13

Primus - graphics issues [Ubuntu]

#1 Post by ttubiana » 2015.04.15 16:29

Hi everyone!

I have an issue when I want to open data with Primus and the other softwares of ATSAS (see picture). When I open these datas on another computer on Ubuntu 14.04 (same distribution), it works, but not on mine.

Does anyone know how to fix that ?

Thank you all!

Thibault.
Attachments
primus_issue.png
primus_issue.png (63.24 KiB) Viewed 5328 times

franke
Administrator
Posts: 408
Joined: 2007.08.10 11:09
Contact:

Re: Primus - graphics issues [Ubuntu]

#2 Post by franke » 2015.04.15 21:15

I take it that you try to open the same file, right? If so, could you please check if the machine that works and yours have different locale? Try:

Code: Select all

$ echo $LANG
en_US.UTF-8
We observed a similar problem with locale before, but assumed that we had it fixed. Maybe not ...?

ttubiana
Member
Posts: 3
Joined: 2015.04.15 16:13

Re: Primus - graphics issues [Ubuntu]

#3 Post by ttubiana » 2015.04.16 08:13

Thank you!
But unfortunatly the two machines have the same $LANG (en_US.UTF-8)...

ttubiana
Member
Posts: 3
Joined: 2015.04.15 16:13

Re: Primus - graphics issues [Ubuntu]

#4 Post by ttubiana » 2015.04.16 08:33

I Managed to fix that :D
What you told me lead me to the good way.

On Ubuntu 14.04 (on Gnome), you have a system menu called "Region & Language". For the "Format" you have to choose "United State" (It was set on "French").
So.. Apparently Primus prefer the Imperial system...

Again Thank you for you help :D

Thibault.

franke
Administrator
Posts: 408
Joined: 2007.08.10 11:09
Contact:

Re: Primus - graphics issues [Ubuntu]

#5 Post by franke » 2015.04.16 08:38

Actually, I'd guess that your file has '.' (3.1415) as a decimal separator and your region setting told primus to expect ',' as a decimal separator (3,1415). Hence the mis-read.

Post Reply