Problem with Primus under Linux

ATSAS for Windows, Linux and Mac, general installation issues, ATSAS online etc.
Post Reply
Message
Author
jiahuichen
Guest
Posts: 2
Joined: 2021.04.12 10:25

Problem with Primus under Linux

#1 Post by jiahuichen » 2021.04.12 11:49

Dear all,

I was wondering if anyone encountered the same issue? Here is the error message:

Code: Select all

 In /usr/lib/qt/plugins/platforms/libqeglfs.so:
     Plugin uses incompatible Qt library (5.15.0) 
   "The plugin '/usr/lib/qt/plugins/platforms/libqeglfs.so' uses incompatible
   Qt library. (5.15.0) " 
            not a plugin
   QFactoryLoader::QFactoryLoader() looking at
   "/usr/lib/qt/plugins/platforms/libqlinuxfb.so"
   Found metadata in lib /usr/lib/qt/plugins/platforms/libqlinuxfb.so,
   metadata=
   {
       "IID":
   "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
       "MetaData": {
           "Keys": 
       },
       "archreq": 0,
       "className": "QLinuxFbIntegrationPlugin",
       "debug": false,
       "version": 331520
   }
   
   
   In /usr/lib/qt/plugins/platforms/libqlinuxfb.so:
     Plugin uses incompatible Qt library (5.15.0) 
   "The plugin '/usr/lib/qt/plugins/platforms/libqlinuxfb.so' uses
   incompatible Qt library. (5.15.0) " 
            not a plugin
   QFactoryLoader::QFactoryLoader() looking at
   "/usr/lib/qt/plugins/platforms/libqminimal.so"
   Found metadata in lib /usr/lib/qt/plugins/platforms/libqminimal.so,
   metadata=
   {
       "IID":
   "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
       "MetaData": {
           "Keys": 
       },
       "archreq": 0,
       "className": "QMinimalIntegrationPlugin",
       "debug": false,
       "version": 331520
   }
   
   
   In /usr/lib/qt/plugins/platforms/libqminimal.so:
     Plugin uses incompatible Qt library (5.15.0) 
   "The plugin '/usr/lib/qt/plugins/platforms/libqminimal.so' uses
   incompatible Qt library. (5.15.0) " 
            not a plugin
   QFactoryLoader::QFactoryLoader() looking at
   "/usr/lib/qt/plugins/platforms/libqminimalegl.so"
   Found metadata in lib /usr/lib/qt/plugins/platforms/libqminimalegl.so,
   metadata=
   {
       "IID":
   "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
       "MetaData": {
           "Keys": 
       },
       "archreq": 0,
       "className": "QMinimalEglIntegrationPlugin",
       "debug": false,
       "version": 331520
   }
   
   
   In /usr/lib/qt/plugins/platforms/libqminimalegl.so:
     Plugin uses incompatible Qt library (5.15.0) 
   "The plugin '/usr/lib/qt/plugins/platforms/libqminimalegl.so' uses
   incompatible Qt library. (5.15.0) " 
            not a plugin
   QFactoryLoader::QFactoryLoader() looking at
   "/usr/lib/qt/plugins/platforms/libqoffscreen.so"
   Found metadata in lib /usr/lib/qt/plugins/platforms/libqoffscreen.so,
   metadata=
   {
       "IID":
   "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
       "MetaData": {
           "Keys": 
       },
       "archreq": 0,
       "className": "QOffscreenIntegrationPlugin",
       "debug": false,
       "version": 331520
   }
   
   
   In /usr/lib/qt/plugins/platforms/libqoffscreen.so:
     Plugin uses incompatible Qt library (5.15.0) 
   "The plugin '/usr/lib/qt/plugins/platforms/libqoffscreen.so' uses
   incompatible Qt library. (5.15.0) " 
            not a plugin
   QFactoryLoader::QFactoryLoader() looking at
   "/usr/lib/qt/plugins/platforms/libqvnc.so"
   Found metadata in lib /usr/lib/qt/plugins/platforms/libqvnc.so, metadata=
   {
       "IID":
   "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
       "MetaData": {
           "Keys": 
       },
       "archreq": 0,
       "className": "QVncIntegrationPlugin",
       "debug": false,
       "version": 331520
   }
   
   
   In /usr/lib/qt/plugins/platforms/libqvnc.so:
     Plugin uses incompatible Qt library (5.15.0) 
   "The plugin '/usr/lib/qt/plugins/platforms/libqvnc.so' uses incompatible Qt
   library. (5.15.0) " 
            not a plugin
   QFactoryLoader::QFactoryLoader() looking at
   "/usr/lib/qt/plugins/platforms/libqxcb.so"
   Found metadata in lib /usr/lib/qt/plugins/platforms/libqxcb.so, metadata=
   {
       "IID":
   "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
       "MetaData": {
           "Keys": 
       },
       "archreq": 0,
       "className": "QXcbIntegrationPlugin",
       "debug": false,
       "version": 331520
   }
   
   
   In /usr/lib/qt/plugins/platforms/libqxcb.so:
     Plugin uses incompatible Qt library (5.15.0) 
   "The plugin '/usr/lib/qt/plugins/platforms/libqxcb.so' uses incompatible Qt
   library. (5.15.0) " 
            not a plugin
   QFactoryLoader::QFactoryLoader() checking directory path
   "/home/aps/Program/ATSAS/bin/platforms" ...
   QFactoryLoader::QFactoryLoader() looking at
   "/home/aps/Program/ATSAS/bin/platforms/libqxcb.so"
   Found metadata in lib /home/aps/Program/ATSAS/bin/platforms/libqxcb.so,
   metadata=
   {
       "IID":
   "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
       "MetaData": {
           "Keys": 
       },
       "archreq": 0,
       "className": "QXcbIntegrationPlugin",
       "debug": false,
       "version": 330752
   }
   
   
   Got keys from plugin meta data ("xcb")
   Cannot load library /home/aps/Program/ATSAS/bin/platforms/libqxcb.so:
   (/home/aps/Program/ATSAS/bin/../lib/atsas/libQt5Core.so.5: version
   `Qt_5.15' not found (required by /usr/lib/libQt5XcbQpa.so.5))
   QLibraryPrivate::loadPlugin failed on
   "/home/aps/Program/ATSAS/bin/platforms/libqxcb.so" : "Cannot load library
   /home/aps/Program/ATSAS/bin/platforms/libqxcb.so:
   (/home/aps/Program/ATSAS/bin/../lib/atsas/libQt5Core.so.5: version
   `Qt_5.15' not found (required by /usr/lib/libQt5XcbQpa.so.5))"
   qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even
   though it was found.
   This application failed to start because no Qt platform plugin could be
   initialized. Reinstalling the application may fix this problem.
   
   Available platform plugins are: xcb.
   
   Aborted (core dumped)
   $
   
 

User avatar
AL
Administrator
Posts: 748
Joined: 2007.08.03 18:55
Location: Hamburg, Germany
Contact:

Version?

#2 Post by AL » 2021.04.12 18:30

Could you please provide the ATSAS version and the OS version (Ubuntu/CentOS/Debian)?

jiahuichen
Guest
Posts: 2
Joined: 2021.04.12 10:25

Re: Problem with Primus under Linux

#3 Post by jiahuichen » 2021.04.13 04:35

Hi AL,

Thank you for the attention.

I am using the 3.0.3 version of ATSAS, and it was running under Arch Linux.

I understand that this distribution is not officially supported, but since this is the environment I am currently working with, I want to give it a shot. I was wondering if you would like give me some hints that could possibly lead to the solution of this issue (qt lib version/PATH, maybe?)

Best regards

====
Edit: I think I find a workaround, set the shared lib path to the ATSAS lib folder:

export LD_LIBRARY_PATH="xxxxx/lib/atsas"

User avatar
AL
Administrator
Posts: 748
Joined: 2007.08.03 18:55
Location: Hamburg, Germany
Contact:

Re: set the shared lib path to the ATSAS lib folder

#4 Post by AL » 2021.04.19 14:53

Cool, thank you for sharing this.

Post Reply