chromixs for MacOS 10.11.6

ATSAS for Linux and Mac, general installation issues, ATSAS online etc.
Post Reply
Message
Author
aemiele
Member
Posts: 3
Joined: 2018.06.07 16:25

chromixs for MacOS 10.11.6

#1 Post by aemiele » 2018.06.07 17:08

Good afternoon,

I have upgraded to ATSAS 2.8.3 and most of the programs run smoothly (I haven't tested them all yet).
Today I am working on CHROMIXS, the files from both BM29 and SWING are correctly loaded, the buffer and sample selections work, the subtracted files are written in the selected directory, BUT primus fails to open directly.
I can open PRIMUS either from the icon or by clicking on the *.dat files, but CHROMIXS complains.
The error is apparently in the path, but I do not know where and how to change the preferences to that.
Here it is the screen error:
Process: primus.bin [6822]
Path: /Users/USER/Documents/*/primus.app/Contents/MacOS/primus
Identifier: vnd.embl-hh.atsas.primus
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: primus.bin [6822]
User ID: 501

Date/Time: 2018-06-07 15:25:49.362 +0200
OS Version: Mac OS X 10.11.6 (15G20015)
Report Version: 11
Anonymous UUID: 56645B05-5CB7-6B87-FE85-30F8CE1E2FCE

Sleep/Wake UUID: 20E3FCB8-0FB2-4BBE-B930-A00D1ACA3CD0

Time Awake Since Boot: 110000 seconds
Time Since Wake: 7900 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /Applications/ATSAS/lib/libQtSvg.4.8.6.dylib
Referenced from: /Users/USER/Documents/*/primus.app/Contents/MacOS/primus
Reason: image not found

Binary Images:
0x7fff67899000 - 0x7fff678d0a47 dyld (360.22) <C8E77F6D-CE86-3C5B-8576-2584A799B51E> /usr/lib/dyld

Model: Macmini3,1, BootROM MM31.00AD.B00, 2 processors, Intel Core 2 Duo, 2.53 GHz, 4 GB, SMC 1.35f1
Graphics: NVIDIA GeForce 9400, NVIDIA GeForce 9400, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353637334548312D4346382020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353637334548312D4346382020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x90), Broadcom BCM43xx 1.0 (5.10.131.39.16)
Bluetooth: Version 4.4.6f2, 3 services, 19 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: Hitachi HTS543232L9SA02, 320.07 GB
Serial ATA Device: OPTIARC DVD RW AD-5670S
USB Device: USB 2.0 Bus
USB Device: USB2.0 Hub
USB Device: Keyboard Hub
USB Device: Apple Optical USB Mouse
USB Device: Apple Keyboard
USB Device: USB 2.0 Bus
USB Device: USB Bus
USB Device: BRCM2046 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB Bus
USB Device: IR Receiver
Thunderbolt Bus:
Any hints? thank you
Adriana

sasha
Active member
Posts: 46
Joined: 2014.03.05 17:56

Re: chromixs for MacOS 10.11.6

#2 Post by sasha » 2018.06.13 22:19

Dear Adriana,

thanks for reporting this issue.
I cannot reproduce the problem, CHROMIXS 2.8.3 opens frames correctly through PRIMUS on MacOS 11.6 (El Capitan).

From the system error message you attach I read:
-a library has not been loaded properly (Library not loaded: /Applications/ATSAS/lib/libQtSvg.4.8.6.dylib)
-an "unofficial" PATH is reported: /Users/USER/Documents/*/primus.app/Contents/MacOS/primus

With such errors, CHROMIXS and PRIMUS should not work at all, but you mention that they work fine.
So, my guess is that you have multiple ATSAS versions installed in your machine.
Please remove old ATSAS versions (particularly the one at /Users/USER/Documents...)

You can leave ATSAS 2.8.3, that should be located at:
/Applications/ATSAS
Which is the only "correct" PATH where ATSAS should be and where the ATSAS 2.8.3 installer would put it.

Please let me know if that helps, otherwise let me know and I will try to help further.
If removing the old ATSAS doesn't work, please open a terminal, type "which primus" and post the output here.

Best,

sasha

aemiele
Member
Posts: 3
Joined: 2018.06.07 16:25

Re: chromixs for MacOS 10.11.6

#3 Post by aemiele » 2018.06.14 10:02

Dear Sasha,

thank you for your reply.
There was nothing in /Users/<anyUSER>/Documents; the old ATSAS was in the /Applications/ but I had zipped it before installing the new version; which is indeed in the correct path, as you can see.
bash-3.2$ which primus
/Applications/ATSAS/bin/primus
bash-3.2$ which chromixs
/Applications/ATSAS/bin/chromixs
bash-3.2$ which sasplot
/Applications/ATSAS/bin/sasplot
After having searched for the missing library (libQtSvg.4.8.7.dylib was the only one in the /Application/ATSAS/lib/ directory), I found an old unzipped version of ATSAS in the backup folder of dropbox.
I zipped it and then CHROMIXS started opening primus correctly.

I did not know that ATSAS was looking for whichever "ATSAS" version in any possible location, but now I know.

Problem solved, thank you very much!

Best,
Adriana

Post Reply