CRYSOL error: Fortran run-time error

Calculation of SAXS and SANS profiles (CRYSOL, CRYSON), superposition of models (SUPCOMB, DAMAVER, DAMCLUST), database DARA
Post Reply
Message
Author
asementilli
Member
Posts: 3
Joined: 2019.04.13 17:53

CRYSOL error: Fortran run-time error

#1 Post by asementilli » 2019.04.13 18:12

Hi all,

New CRYSOL user here.

While I'm not a really a SAXS practitioner, I use CRYSOL to verify the validity and stability of molecular dynamics simulations by comparing the diffraction reflections to experimental pXRD/WAXS data.

In short, I have WAXS and XRD data for peptide assemblies that arrange themselves into a crystalline-like lattice. I can build models of these assemblies in molecular graphics software according to experimental constrains, export them as PDBs, and generate a simulated diffraction pattern using CRYSOL.

My difficulty is when I try to take this model, run it through molecular dynamics, and use a PDB generated from the final frame of the trajectory in CRYSOL, I obtain a Fortran run-time error:
"forrtl: severe (408): fort: (4) Variable AUXLINE has substring ending point 129 which is greater than the variable length of 128"

I've tried re-exporting the trajectory frame coordinates from two different software (Maestro and VMD), but this error message comes up with every PDB I submit following and MD job.

To verify the software I have is functional, I loaded an older model file before simulating it, and CRYSOL read and exported an intensity plot just fine.

Looking around this forum, I see a handful of other people encounter this issue, and the reason seems to be something wrong with the PDB itself. But, peculiarly, I tried submitting the job to the online version of CRYSOL (https://www.embl-hamburg.de/biosaxs/atsas-online/), on this "problematic PDB," and it worked. The problem is that the online submission form wouldn't let me plot beyond an A-1 = 1, and I need a maximum angle = 2 to fully analyze my data.

Do you know if there's a way to extend the max angle on the online submission form or a way to figure out what PDB issues could be causing this fortran issue?

Thanks!

-Anthony

SaxsMax
Administrator
Posts: 347
Joined: 2007.08.03 19:16

Re: CRYSOL error: Fortran run-time error

#2 Post by SaxsMax » 2019.04.25 14:46

Hi Anthony,
Could you please attach the PDB file causing the error?

asementilli
Member
Posts: 3
Joined: 2019.04.13 17:53

Re: CRYSOL error: Fortran run-time error

#3 Post by asementilli » 2019.04.26 22:49

Hi SaxsMax,

Thanks for your reply.

I don't know how to attach files on forums, so I uploaded the pdb to google drive and pasted a download link below. I hope that's acceptable for this server.

https://drive.google.com/file/d/1J4RQsU ... sp=sharing

-Anthony

SaxsMax
Administrator
Posts: 347
Joined: 2007.08.03 19:16

Re: CRYSOL error: Fortran run-time error

#4 Post by SaxsMax » 2019.04.27 11:45

Hi Anthony,

I've been able to run the following command on Win 10, Atsas 2.8.4 without any problems
crysol K16Abilayer_no_metal_optimized_SPC_frame150_exported_watersdeleted_Cldeleted_unboundHdeleted.pdb -sm 2.0 -ns 201

Which platform/Atsas version do you use?

Try maybe to shorten the pdb file name length.

asementilli
Member
Posts: 3
Joined: 2019.04.13 17:53

Re: CRYSOL error: Fortran run-time error

#5 Post by asementilli » 2019.04.27 19:37

It worked! So glad it was an easy fix--thanks for your suggestion. I also have 2.8.4 installed.

Post Reply