Error running dammif with 'small' data

Ab initio modelling: DAMMIF, DAMMIN, GASBOR, MONSA
Post Reply
Message
Author
jbhopkins
Active member
Posts: 15
Joined: 2014.10.22 21:21
Location: BioCAT, Advanced Photon Source

Error running dammif with 'small' data

#1 Post by jbhopkins » 2020.01.08 18:38

Hi folks,

I'm using DAMMIF from ATSAS 3.0.0 on MacOS 10.14.6. When I try to run dammif on the attached GNOM .out file in fast mode, I get the following error:
"error: initial shape dimensions too small, check units"

This happens regardless of whether I run it in interactive mode or with command line arguments. It doesn't matter if I specify the unit (Angstrom) or leave it to the default Unknown.

If I do reconstructions in slow mode it starts and seems to run just fine.

If I scale the overall scattering profile intensity by 1000, then regenerate the P(r) with the same Dmax, both modes seem to work.

Does DAMMIF have a minimum cutoff intensity that it needs to run? Or is there something else wrong here?

Thanks.

- Jesse
Attachments
data.out
(52.25 KiB) Downloaded 37 times

franke
Administrator
Posts: 409
Joined: 2007.08.10 11:09
Contact:

Re: Error running dammif with 'small' data

#2 Post by franke » 2020.01.27 22:28

Hi Jesse.

In slow mode:

Code: Select all

Shape class ...................................... : extended
Approx. shape dimension (ri) ..................... : 0.00
Approx. shape dimension (ro) ..................... : 16.8
Approx. shape dimension (h) ...................... : 168.
Dummy atom radius ................................ : 3.00
The difference is, that in slow mode, the cross section of the extended shape allows for ten to eleven beads (33A/3A), while in fast mode, the cross section would be constructed by about six beads (33A/5A). Thus the error message - so far, whenever I observed this kind of issue, the units were wrong. Not very well worded for this case.

Starting in "interactive" mode and setting "expected/assumed shape" as "unknown" and "dummy atom radius" to "5.0" should give similar results as fast mode, but without the error message.

There is no (known or explicit) check for intensity scales. I'd expect that you observed some issue with rounding errors, maybe?

HTH

Daniel

Post Reply